These forums are now Read Only. If you have an Acrobat question, ask questions and get help from one of our experts.

Tab sequence will not order correctly.

ellisw
Registered: Jul 28 2006
Posts: 10

Created a form in Livecycle then tried to re-order Tabs to proper sequence of input blocks. In going thru the renumbering, by the book, there was nothing I could do to correct the sequence; the designer having made up it's mind as to what sequence went where, randomly and nonsensical. Support and Forums suggestions were unsuccessful. I will appreciate any contributions from anyone experiencing the phenom and especially anyone who can provide cause and corrective procedure.

rhelmer
Registered: Jul 17 2007
Posts: 5
Is your keyboard new or an old keyboard? The problem may be that when you start the process by selecting View, then Tab Order, then Holding down the Shift Key and selecting the first block ....and at the end selecting View, then selecting Tab Order. Your keyboard is not recognizing the depression of the Shift Key and therefore the Tab Order process is not initiated.

Good Luck!
hdubitzky
Registered: Aug 6 2007
Posts: 7
Hi rhelmer,

For sure there is a bug in Acrobat with tabbing order.

I have followed "by the book" instructions, "resetting" the tabbing order, but nothing works. In fact, the tabbing order is now completely disorganized beyond any sense. The only thing I came up with was to use the tabbing order by rows. Although not perfect, at least it works as expected.

Hopefully Adobe will fix this bug soon.

Regards,
Haim
hunths
Registered: Aug 9 2007
Posts: 9
In Acrobat Forms version 8, I had issues with not being able to set the tabbing order on fields in an Acrobat Form. Whenever I clicked on Forms/Edit Fields, the Set Tabbing Order item was always grayed out.

This is what I now do, which has fixed the issue for me. I have no idea why it works, but it worksfor me. On the toolbar, there is a button called "Preview." I click on that button and it turns into "Edit Layout." Click on the "Edit Layout" button and it will turn back into "Preview." Now if you go to Forms/Edit Fields, you should be able to select "Set Tab Order." Select the fields in the desired order and it should save the order.

Hopefully this will work for you.
jodie7111
Registered: May 22 2007
Posts: 9
I am having this problem too, but cannot find a 'preview' button. Please could you advise where to find it??

Thanks
StevenD
Registered: Oct 6 2006
Posts: 368
The first question started out dealing with a LiveCycle Designer form. Are we now talking about setting the tab order in a AcroForm form?

And I can't see a Preview button in Acrobat Professional 8.1 either.

StevenD

TP
Registered: Sep 30 2007
Posts: 11
I have found that there are some major issues with tabbing in Pro 7 LiveCycle. Not only do i manually set the tabbing order, but place everything in hierarchy in the correct order with subform wrapping, and yet if there is a radio button in the form the entire tabbing goes crazy.
I was told that Pro 8 is alot better for this, however, its not worth looking at with all the issues of "gemlins" we encounted with it
cmschofield
Registered: Nov 28 2007
Posts: 1
Just in case anyone is still interested, the reason why the Set Tab Order is grayed out in Acrobat 8 Pro can be found here

http://help.adobe.com/en_US/Acrobat/8.0/Professional/help.php?content=WS58a04a822e3e50102bd615109794195ff-7deb.php

Click the "Set tabbing order manually" option:

"You can choose this command only if the tab order property in the Page Properties is set to Unspecified."

- C
lkassuba
ExpertTeam
Registered: Jun 28 2007
Posts: 3636
ellisw wrote:
Created a form in Livecycle then tried to re-order Tabs to proper sequence of input blocks. In going thru the renumbering, by the book, there was nothing I could do to correct the sequence; the designer having made up it's mind as to what sequence went where, randomly and nonsensical. Support and Forums suggestions were unsuccessful. I will appreciate any contributions from anyone experiencing the phenom and especially anyone who can provide cause and corrective procedure.
Have you tried this specific tip for setting tabbing order in a LiveCycle form?
http://www.adobeforums.com/[email protected]@.3bc2e7fa/21

In regards to setting tab order in Acrobat 8, you cannot do this if the form was created in LiveCycle. However, if the form was created in Acrobat just remember to set the page properties Tab Order to Unspecified if you want to manually set the tab order.
Page Navigation Pane, Right-click on the page and select Page Properties. Under the Tab Order menu selected Unspecified.

Lori Kassuba is an AUC Expert and Community Manager for AcrobatUsers.com.

jonchalk
Registered: Dec 15 2007
Posts: 8
I finally found the page properties and the "tab order" tab (Click the Pages button or choose View > Navigation Panels > Pages to open the Pages panel.
Select one or more page icons, and choose Page Properties in the Pages panel Options menu.
Select a Tab Order option: where there are 4 options: use row order, use column order, use document structure and unspecified.

But those too are greyed out. What do I do? The form was originally created under Adobe Acrobat 8.0 Professional.
gkaiseril
Expert
Registered: Feb 23 2006
Posts: 4307
Setting the tab order needs to be done within the application that created the form. That is either Acrobat using the Form Tool or LiveCycle Designer. Since the option is grayed out in Acrobat, I suspect you created the form in LiveCycle Designer. Both of these products are included in distribution version of Acrobat Professional.

George Kaiser

beklaus
Registered: Mar 3 2008
Posts: 5
I just learned something new in this arena... if you have fields that are being set to "protected" by a script, in order to prevent user from entering them, the tabbing is disabled which screws up the tab order. It not only skips the protected field, but it does not know pick up at the next open field, it is hard to predict where the tab may take you!

I am being forced to use "readOnly" which still enables tabbing to the field, just no data change. This is not a great solution if user has to tab through a bunch of dead fields to get to next open one.
firebirdbandit
Registered: Jan 23 2008
Posts: 9
I've heard this is a bug. I found a workaround but it really is a pain. This is what I had to do. Open the pdf in Acrobat and choose view then navigation panels then order. Choose the page you want to reorder and delete everythign under it. Then with see the options button in that order window. Click on that and choose show reading order panel. You you must do is select each field and make sure they numbers follow the sequence you want. This tool is tricky to use so it takes some practice. When you are done and everything is in the right sequence. Save it. Then open with Livecycle and do the tab order thing again, by shift clicking the first item then clicking each next item you want in order, even if it is already correct. Then save it and your problem should be fixed.
beklaus
Registered: Mar 3 2008
Posts: 5
I have found a solution to this too and created a document to use internally at my company... I will cut and paste here, unfortunately, the images will be missing:
-------------------------------------------------
Tab Problems with LiveCycle Designer:

In LiveCycle Ver 8.xx tabbing has been a big problem. I have determined the cause of these problems to be the manual tab definition process (View->Tab Order). When tab order is defined by this process, it creates nodes in the XML of the .xdp document. These nodes are supposed to dictate tab order at Runtime. These do not appear to be working correctly in Adobe Acrobat and it is causing headaches for anyone trying to set tab order for their documents.My Solution:
The default tab order for a pdf document created in LiveCycle is just to go from top to bottom based on the Y-axis of the objects. So, I am just going through my forms and aligning everything at its top (Y-axis) position.

To align a simple row of fields:
1. Select all the fields in a row (either by right-click dragging and grabbing them or by CTRL-Clicking the individual fields.)
2. Then go to menu Layout->Align->TopIf the form has groups of checkboxes and dropdowns next to each other then:
1. Wrap in Subforms - it is best to put vertically aligned fields within a Subform (select and right click – “Wrap in Subform”) and then put another group of vertically aligned fields into another Subform so they can be next to each other.
2. Align the Subforms – select the Subforms in the Hierarchy on left. Then do the Align->Top for the Subforms. (Be careful to just CTRL-click the root of the Subforms, not select all the fields within the Subforms.)Gotchas:
Sometimes, after you select and align some fields, they still tab in a strange order. If that happens there are a few things to try.

1. Select your fields and look at the Layout tab. If the Y: axis says mixed then the Y axis is not aligned.
2. If not aligned, I would select just one field, copy its Y axis value, go back and select all the fields and overwrite the mixed value with your copied value, thus setting all Y axis values to same.
3. If this is still not working, I would check your Subform borders. Click on the Subform Root in the Hierarchy and look at the border that highlights on the designer. If the space is a lot bigger than necessary, I would adjust it to only contain the elements it should. Sometimes these borders overlap other Subforms and cause problems with Tabs.

Finally, if you go into the Tab Order process (View->Tab Order) for any reason and then save the changes, this will create the Traversal nodes in the xdp document. These can corrupt your tabbing order. To get rid of them, view the xdp document in a text reader and go through and delete all the Traversal nodes and save.Bottom Line: if you can avoid using the Tab Ordering functionality, your tabs will always be predictable... top to bottom.
firebirdbandit
Registered: Jan 23 2008
Posts: 9
Does anyone know if this problem exists in Acrobat 9. I would only update if they fixed it in Acrobat 9.
lkassuba
ExpertTeam
Registered: Jun 28 2007
Posts: 3636
In Designer 8.2 (ships with Acrobat 9 Pro+), there is a new feature just to work with the tab order. Here is the info. taken from the New Features documentation.

"Enhanced to make it easier for you to view and change tabbing order in a form design. The new Tab Order palette displays a numbered list of all the objects on the form, where each number represents the position of the object within the tabbing order. The palette also displays visual markers in the list; for example, it displays a range of numbers to indicate objects within a fragment reference.
By default, tabbing order is automatic, but you can set custom tabbing order on your form."

Here is more information from the Developer Center on [url=http://www.adobe.com/devnet/livecycle/articles/whatsnew_lcesupdate1_designer.php]Tab Order Authoring changes in the latest LiveCycle Designer update[/url].

Lori Kassuba is an AUC Expert and Community Manager for AcrobatUsers.com.

Hammari
Registered: Mar 25 2008
Posts: 16
I found that saving the pdf as an Acrobat 7 pdf provided more consistent (but not perfect) results after manually setting tabbing order.
sepi
Registered: Aug 24 2008
Posts: 1
my problem with tab ordering was fixed by changing the hierarchy of the field objects and renaming the fields in the hierarchy panel.

in LiveCycle, i choose Hierarchy from the Window menu (SHIFT+F11)
then i dragged the fields in the order they had to be. i also renamed all the fields in the Hierarchy Pannel. i thought if there are any bugs associated with the script this renaming might help!

then i went back to reordering the tabs. did so by choosing the Toolbars from the Window menu. one of the toolbars that will open up is called "Tools" and there is an icon called "Tab Order" by clicking on it and doing the Shit+click for fist tab selection and clicking on the rest of the fields in order i made sure the tabs were set to order.
mbritt3
Registered: Jun 7 2009
Posts: 1
Don't bother getting excited about Adobe fixing the problems with the tabbing order in Livecycle Designer 8.2.
I bought the newest version hoping that this bug had been fixed... it crashes worse than my older version. I can't manually change the tab order by using F2, if I use the up/down arrows, drag and drop of copy/paste it shuts down.
When I save the little work that did tab correctly, it will be messed up next time I open the file.
Welcome to Adobe.com, land of the crappiest software known to man.
web_wolf
Registered: Jan 24 2008
Posts: 39
mbritt3,

I completely agree with you there!! I got the new version (8.2) hoping it would be better, sure it may seem like it's better, but it's still got a ton of bugs. Adobe even screwed up my registry somehow and the only way for me to fix the problem, according to Adobe's un-technical technical support, was to create a new profile on my machine. Normally it wouldn't have been that big of a deal, but this was my work machine. Caused a co-worker several hours to set everything up and me 3 hours to get my new profile the way I want it. LiveCycle is great for simple dynamic forms, but if you want to get advanced with it, forget it! It'll cause you more headaches then it's worth. Plus, learning the new script is a pain. I don't know why they can't just use plain JavaScript...

Website Designer - Lititz, PA

web_wolf
Registered: Jan 24 2008
Posts: 39
Hi Ramformer,

You might want to start your own thread for that kind of question. Tab order isn't really related to Global fields...

Website Designer - Lititz, PA

tonyshangrila
Registered: Mar 18 2010
Posts: 1
Sorry for the necro-post on this topic, but in case someone else lands here:
A form that I created in LiveCycle Designer 7.0 appeared to have tab fields all out of whack in the 'PDF Preview' available within LiveCycle. However, when I opened the form in Acrobat, everything tabbed correctly.

???
mitch54
Registered: Jun 1 2010
Posts: 30
Using Acrobat 8, when I try to manually set the tab order, which SHOULD be starting with #1, my tabs number backwards when I just click on the number and try to set a first tab. In other words, when I clicked on the field I wanted to be tab #1, it made it tab #246. Anyone have that problem??
deBare
Registered: Jan 16 2009
Posts: 6
mitch54 wrote:
Using Acrobat 8, when I try to manually set the tab order, which SHOULD be starting with #1, my tabs number backwards when I just click on the number and try to set a first tab. In other words, when I clicked on the field I wanted to be tab #1, it made it tab #246. Anyone have that problem??
The only way I found to make the Tabbing Order work manually in Acrobat 8.2.2 was, in fact, to work backwards. Since the first field seemed to be okay, I clicked on a the second field, which became 67, and the third field which became 67, making the second field 66 ... and so on and so on through the entire sequence.

After I clicked every field in the order I wanted, letting Acrobat count the fields down backwards, it turned out exactly the way I wanted it. But what a pain!!!!!! I can't imagine doing this with 246 fields ... aaargh.
MarlaZ
Registered: Apr 28 2010
Posts: 112
I created a form with many Radio buttons.

In order for them to be "Mutually Exclusive" - which I need (rather than check boxes, which are not mutually exclusive unless someone knows how to make them so) - the Radio Buttons have to be in a group.

Now trying to set Tab order, only ONE of the buttons of each group gets a tab.

!!

How is this helpful!??

So my choice is between Checkboxes which tab through but are not mutually exclusive - meaning both checkboxes can be checked at the same time

OR

Mutually Exclusive Radio Buttons that don't tab through.

If someone knows how to make checkboxes mutually exclusive, I am listening.

Marla

web_wolf
Registered: Jan 24 2008
Posts: 39
Marla,

I too think it's dumb to have the radio/check boxes setup that way. It's not like that on the internet, so why here? Adobe has a TON of bugs within this program and they are a pain to get around just to get your page to act "normal". I wish they would come up with an update that could actually fix these tabbing issues.

You have a couple options:

1. If you use the arrows on your keyboard, you will be able to change your radio button selection.

2. Make your radio buttons check boxes and write script to not allow more than one answer for your groups.

Hope this helps.

Website Designer - Lititz, PA

jonom
Registered: Jan 31 2008
Posts: 133
MarlaZ wrote:
If someone knows how to make checkboxes mutually exclusive, I am listening.
It's quite easy but a bit of a pain - when the checkbox is clicked on you turn off the other checkboxes.

if (this.rawValue == 1)
{
checkbox2.rawValue = 0;
checkbox3.rawValue = 0;
//etc.
}

You may want to take a look at John Brinkman's exclusion group script object. It's pretty slick. One really cool feature is that you can have disparate objects as part of an exclusion group - like a couple of checkboxes, a text field, etc. There are a couple of other script objects in his posts to do with validation that are pretty slick as well.
http://blogs.adobe.com/formfeed/2008/12/exclusion_groups_v40.php

It's worth reading the whole series of posts (parts 1-3).

Latest version of the script objects are in this post (as far as I know):
http://blogs.adobe.com/formfeed/2009/03/a_form_to_design_a_form.php